読者です 読者をやめる 読者になる 読者になる

simanのブログ

ゆるふわプログラマー。競技プログラミングやってます。Ruby好き

Rails3とRmagickの環境構築で苦労した話

 Rails上でRMagickを動かそうと思って、早速RMagickを入れようとしたのだが

なんかエラーが出てインストールできなかった。とりあえず色々解決法を探した結果

 

* とりあえずImageMagickとRMagickをアンインストールしよう *

brew uninstall imagemagick

gem uninstall rmagick

 

* もう1回インストールし直す *

brew install imagemagick

 

* シェルのコンフィグにパスを通しておく *

export DYLD_LIBRARY_PATH=/usr/local/Cellar/imagemagick/6.7.7-6/lib

 

* GemfileにRmagickを使用するための記述を行う *

gem "rmagick", "2.12.0" , :require => 'RMagick'

gem "mini_magick", "~> 3.4"

 

* bundle installを行う *

bundle install 

 

自分はこれでうまくいきました。

Rails 3.2.11

ruby 1.9.3p286